Increased latencies in US Hosted environment

Incident Report for Etleap

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 21:49 PDT

Monitoring

We have applied a fix, and we are currently monitoring the recovery.
Posted Mar 17, 2026 - 21:36 PDT

Investigating

We are currently investigating the issue
Posted Mar 17, 2026 - 20:58 PDT
This incident affected: US Hosted App (app.etleap.com) (Pipelines).