Hosted App is Unavailable

Incident Report for Etleap

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 13:01 PDT

Investigating

The hosted App UI is currently unavailable. We are currently investigating the issue
Posted Aug 07, 2026 - 11:55 PDT
This incident affected: US Hosted App (app.etleap.com) (UI).