The incident is currently impacting pipelines that load data into Iceberg. Both the UI, API and Pipelines are affected by this incident.
Pipelines that load into Snowflake, Redshift, Databricks Delta Lake, and S3 Data Lake are unaffected by this incident, and are processing data normally.
We are identified the root cause as an AWS service that's currently down for this environment. We are currently working with AWS to restore the service.
We'll provide updates every 30 minutes, or sooner if required.
Posted May 27, 2026 - 10:35 PDT
Identified
We have identified the issue, and we are currently working on a resolution.
Posted May 27, 2026 - 10:21 PDT
Investigating
We are currently investigating an issue with our metrics service affecting pipelines in Hosted US
Posted May 27, 2026 - 09:10 PDT
This incident affects: US Hosted App (app.etleap.com) (UI, Pipelines, API).