We are seeing increased pipeline latencies

Incident Report for Etleap

Resolved

This incident has been resolved and affected pipelines have recovered.
Posted May 29, 2026 - 22:57 PDT

Monitoring

We have applied the fix, and we are monitoring pipeline recovery
Posted May 29, 2026 - 22:29 PDT

Identified

We have identified the issue, and are working on a fix.
Posted May 29, 2026 - 22:07 PDT

Investigating

We are currently investigating the issue
Posted May 29, 2026 - 21:13 PDT
This incident affected: US Hosted App (app.etleap.com) (Pipelines).