X (Twitter) Ads Reports Pipelines Failing Extractions

Incident Report for Etleap

Resolved

This incident is caused by an upstream issue with X's API. We have filed a bug report [1], and notified all affected customers.

We will continue to monitor until this incident is resolved on X's side. We will reach out directly to affected customers with any updates.

[1]: https://devcommunity.x.com/t/api-stats-jobs-returning-empty-or-broken-data/262900
Posted Apr 15, 2026 - 15:09 PDT

Identified

We are currently experiencing errors with extractions from Twitter Ad Reports in all environments. We've identified the issue to be on Twitter's API and are monitoring the situation.

All report entities are currently affected.
Posted Apr 15, 2026 - 10:51 PDT
This incident affected: Integrations.