Hosted-EU CDC pipelines impaired

Incident Report for Etleap

Resolved

Earlier today between approximately 10:57 UTC and 11:20 UTC, a power outage in an AWS data center caused all DMS tasks in our hosted EU environment to restart. The restart resulted in corrupted CDC files being written to S3 (zero-filled regions and partial records), as well as a small amount of data loss between the last good file and the first post-restart file. We have opened a dialog with the DMS team at AWS and are pushing for a post-mortem on their side.

We have identified all potentially affected pipelines and notified the impacted customers directly with next steps. If you have not received a notification from us, your pipelines were not affected. We will be working with the DMS team to explore ways to guarantee that future power outages won't cause data integrity issues.
Posted Apr 27, 2026 - 23:04 PDT

Update

We have determined that the parsing errors are anomalous, i.e. that pipelines that are configured not to stop on parsing errors are unaffected by this issue. We are currently determining whether any pipelines are stopped as a result of these anomalous parsing errors.
Posted Apr 27, 2026 - 17:33 PDT

Identified

Some pipelines using CDC sources are partially impaired. You may see parsing errors as a result of the DMS files produced during the earlier AWS outage that affected the eu-west-3 Paris region.
Posted Apr 27, 2026 - 10:05 PDT
This incident affected: EU Hosted App (app.eu.etleap.com) (Pipelines).